PAT--甲 1041 Be Unique

甲 1041 Be Unique (题解)

1041 Be Unique (题解)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,1000 ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

输入格式:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10000 ) and then followed by N bets. The numbers are separated by a space.

输出格式:

For each test case, print the winning number in a line. If there is no winner, print None instead.

输入样例1:

1
7 5 31 5 88 67 88 17

输出样例1:

1
31

输入样例2:

1
5 888 666 666 888 888

输出样例2:

1
None

思路:

追个接收数字,用哈希数组进行计数,如果该数字第一次出现,则将该树存储在b中,则b中存储的为出现过的数字,再利用数组b进行判断,如果第一次出现且只出现一次,则输出该树,如果没有符合范围的则输出”None”。

我的代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include <stdio.h>
int main()
{
int N,count=0;
scanf("%d",&N);
int a[10010]={0};
int b[10010]={0};
for(int i=0;i<N;i++)
{
int m;
scanf("%d",&m); \\输入m,并记录次数
a[m]++;
if(a[m]==1) \\如果是第一次,该数字第一次出现,将该数字存储在b中
b[count++]=m;
}
int j;
for(j=0;j<count;j++)
if(a[b[j]]==1)
{
printf("%d\n",b[j]);
break;
}
if(j==count)
printf("None\n");
return 0;
}
小礼物走一个哟
0%